#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<record.*>(\n\s*((?!<\/record>).+)\n)?\s*<\/record>"
Local $sString = " <record ID="0" dataID="0x0">" & @CRLF & _
" " & @CRLF & _
" </record>" & @CRLF & _
" <record ID="1" dataID="0x0">" & @CRLF & _
" тут может быть всё, что может быть напечатано" & @CRLF & _
" </record>" & @CRLF & _
" <record ID="2" dataID="0x0">" & @CRLF & _
" тут может быть всё, что может быть напечатано" & @CRLF & _
" </record>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")