import re
regex = re.compile(r"<record.*>(\n\s*((?!<\/record>).+)\n)?\s*<\/record>", flags=re.MULTILINE)
test_str = (" <record ID=\"0\" dataID=\"0x0\">\n"
" \n"
" </record>\n"
" <record ID=\"1\" dataID=\"0x0\">\n"
" тут может быть всё, что может быть напечатано\n"
" </record>\n"
" <record ID=\"2\" dataID=\"0x0\">\n"
" тут может быть всё, что может быть напечатано\n"
" </record>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")