using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"alt='(?:\K[^']+|')";
string input = @"alt='Text-01'
alt='Text 02'
alt=''
alt='Some long text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}