$re = '/alt=\'(?:\K[^\']+|\')/m';
$str = 'alt=\'Text-01\'
alt=\'Text 02\'
alt=\'\'
alt=\'Some long text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);