package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}[@&][A-Z]{4}$`)
var str = `21@YOUR
74&GOOD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}