$re = '/^\d{2}[@&][A-Z]{4}$/m';
$str = '21@YOUR
74&GOOD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);