using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#a(?=.*\))(?!.*\()";
string substitution = @"";
string input = @"abc#axyz(abc#axyz#a#aabc)abc#axyz";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}