re = /#a(?=.*\))(?!.*\()/m
str = 'abc#axyz(abc#axyz#a#aabc)abc#axyz'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result