package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)System\.out\.println\(\"[^\":]*\b(?:job|jb?c)\b[^\"]*\"[^)]*\);`)
var str = `System.out.println("my job code is: " var.jobcode);
System.out.println("my jc is: " var.jc);
System.out.println("my jbc is: " var.jbc);
System.out.println ("component printout: item"); System.out.println (""); <td style="word-break: break-all;word-wrap:break-word;font-size:12px;" class="FONTSTYLE" align="left">Job Codes</td><td style="word-break: break-all;word-wrap:break-word;font-size:12px;" class="FONTSTYLE" align="left">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}