import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "System\\.out\\.println\\(\\\"[^\\\":]*\\b(?:job|jb?c)\\b[^\\\"]*\\\"[^)]*\\);";
final String string = "System.out.println(\"my job code is: \" var.jobcode);\n\n"
+ "System.out.println(\"my jc is: \" var.jc);\n\n"
+ "System.out.println(\"my jbc is: \" var.jbc);\n\n"
+ "System.out.println (\"component printout: item\"); System.out.println (\"\"); <td style=\"word-break: break-all;word-wrap:break-word;font-size:12px;\" class=\"FONTSTYLE\" align=\"left\">Job Codes</td><td style=\"word-break: break-all;word-wrap:break-word;font-size:12px;\" class=\"FONTSTYLE\" align=\"left\">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}