$re = '/(?<!\\\\) # Check it was not escaped with a \
(?<bold_all>
(?<bold_type>\*{2}|\_{2}) # Emphasis type: * or _
(?= # followed by non-space
(?:
(?:[_*`\$\\\\]) # avoid punctuation except those
|
(?![[:punct:]])
)
\S)
(?<bold_text>.+?[*_]*) # enclosed text
(?<=\S) # making sure preceding stuff was a non-space
\g{bold_type} # Balanced closing tag
)/x';
$str = '**_test_ test**
*test **test***
E**. **Test** TestTestTest
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);