re = /(?<!\\) # Check it was not escaped with a \
(?<bold_all>
(?<bold_type>\*{2}|\_{2}) # Emphasis type: * or _
(?= # followed by non-space
(?:
(?:[_*`\$\\]) # avoid punctuation except those
|
(?![[:punct:]])
)
\S)
(?<bold_text>.+?[*_]*) # enclosed text
(?<=\S) # making sure preceding stuff was a non-space
\g{bold_type} # Balanced closing tag
)/x
str = '**_test_ test**
*test **test***
E**. **Test** TestTestTest
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end