import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(AllowUsers )(?>(.*)?(\\bbob\\b)(.*)|(.*))$";
final String string = "AllowUsers richard\n"
+ "AllowUsers richard jeremy\n"
+ "AllowUsers james richard jeremy\n"
+ "AllowUsers jeremy\n"
+ "AllowUsers bob\n"
+ "AllowUsers bob billybob\n"
+ "AllowUsers billybob bob\n"
+ "AllowUsers billybob steve bob eric bobby\n"
+ "AllowUsers billybob bobby steve bob eric\n"
+ "AllowUsers richard bob\n"
+ "AllowUsers richard bob jeremy\n"
+ "AllowUsers bob james richard jeremy\n"
+ "AllowUsers bob jeremy\n"
+ "abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}