const regex = /^(AllowUsers )(?>(.*)?(\bbob\b)(.*)|(.*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(AllowUsers )(?>(.*)?(\\bbob\\b)(.*)|(.*))$', 'gm')
const str = `AllowUsers richard
AllowUsers richard jeremy
AllowUsers james richard jeremy
AllowUsers jeremy
AllowUsers bob
AllowUsers bob billybob
AllowUsers billybob bob
AllowUsers billybob steve bob eric bobby
AllowUsers billybob bobby steve bob eric
AllowUsers richard bob
AllowUsers richard bob jeremy
AllowUsers bob james richard jeremy
AllowUsers bob jeremy
abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}