package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<urlPthTxt_new>\/\w+\/\w+)`)
var str = `/v1/product
/v1/product/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}