import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<ts>[\\d.]+).*(?P<func>(?<= )\\S+(?=\\+)|(?<=\\[)[^\\]]+).*?returned (?P<ret>\\d+) after (?P<val>\\d+)";
final String string = "[ 1.765989] initcall init_module.cfi_jt+0x0/0x8 [altmode_glink] returned 0 after 379 usecs\n"
+ "[ 0.001873] initcall selinux_init+0x0/0x1f8 returned 0 after 85 usecs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}