use strict;
my $str = '[ 1.765989] initcall init_module.cfi_jt+0x0/0x8 [altmode_glink] returned 0 after 379 usecs
[ 0.001873] initcall selinux_init+0x0/0x1f8 returned 0 after 85 usecs';
my $regex = qr/(?P<ts>[\d.]+).*(?P<func>(?<= )\S+(?=\+)|(?<=\[)[^\]]+).*?returned (?P<ret>\d+) after (?P<val>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}