$re = '/^[^_]*([_])[^_]*\1[^_]*$/im';
$str = 'no underscore
one_underscore
two_underscores_here
three_underscores_are_here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);