re = /^[^_]*([_])[^_]*\1[^_]*$/im
str = 'no underscore
one_underscore
two_underscores_here
three_underscores_are_here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end