import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^!\\R\\Kinterface.*\\R(?=!$)";
final String string = "!\n"
+ "interface GigabitEthernet0/0\n"
+ " shutdown\n"
+ "!\n"
+ "interface GigabitEthernet0/1\n"
+ "!\n"
+ "interface GigabitEthernet0/2\n"
+ " shutdown\n"
+ "!\n"
+ "interface GigabitEthernet0/3 \n"
+ "!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}