re = /(?m)^!\R\Kinterface.*\R(?=!$)/
str = '!
interface GigabitEthernet0/0
shutdown
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
shutdown
!
interface GigabitEthernet0/3
!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end