re = /(0*10*)((11)*|0*)((0*10*10*)*|111)0*/
str = '01
01
001
00000100000011
1000
111
0001110110000
0010010001
0000000100000000
000000011111110000000
000000000100000000
0000000111
0
00
0010010011111111100
01110000
000001110000
01110111000111
011101010101
0111010101011111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end