$re = '/(?<=_)[12]\d{3}_[01]\d_[0123]\d(?=_)/m';
$str = 'CRC_recup_backup_2018_11_20_004003_1817970.bak
CRC_recup_backup_2018_11_21_004001_6027986.bak
CRC_recup_backup_2018_11_22_004001_7717997.bak
CRC_Test_backup_2018_11_16_004002_9068137.bak';
$subst = "2020_08_09";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;