$re = '/^(b.*)?(foo.{0,2})$/m';
$str = 'foo
bla foo
bla foob
bla bla foobc
foo bla foobcc
fooabcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);