import re
regex = re.compile(r"^(b.*)?(foo.{0,2})$", flags=re.MULTILINE)
test_str = ("foo\n"
"bla foo\n"
"bla foob\n"
"bla bla foobc\n\n\n"
"foo bla foobcc\n"
"fooabcd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")