package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+\.)+\s+(.+)$`)
var str = `A. E. Pelaez Santos
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}