using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"filename.txt_[0-9]*.abc";
string input = @"filename.txt_32423442.abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}