$re = '/filename.txt_[0-9]*.abc/m';
$str = 'filename.txt_32423442.abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);