package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?[0-9]*\.?[0-9]+$`)
var str = `345.34
345.
234.45.
PZ033GB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}