$re = '/^[-+]?[0-9]*\.?[0-9]+$/m';
$str = '345.34
345.
234.45.
PZ033GB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);