using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^Datapath\s)(?<to>.*)\s(?=service\sentered)service\sentered\sthe\s(?<state>\w+)\sstate\.$";
string input = @"The McAfee Validation Trust Protection Service service entered the running state.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}