$re = '/(?<=^Datapath\s)(?<to>.*)\s(?=service\sentered)service\sentered\sthe\s(?<state>\w+)\sstate\.$/m';
$str = 'The McAfee Validation Trust Protection Service service entered the running state.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);