using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\*)(\/([0-5]?[0-9]))?|(([0-5]?[0-9])(\/([0-5]?[0-9]))?(-([0-5]?[0-9]))?(,([0-5]?[0-9]))*))$";
string input = @"*
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
*/3
*/3/3
62
63
64
65
0/5
0/5/2
14,18
14,18,14,18,14,18
3-39
3-39-50
14,18,3-39,52";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}