import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\w-])(excel|technology|technology-based|c#|software & framework|\\.net)(?![\\w-])";
final String string = "BIexcel communications excel, nibh excellent communications quis technology- software & framework C# Quisque convallis communication technology-based skills vulputate excel. \n"
+ "auctor excellent blandit and c++ catoon .net luctus. .net microsoft self-excel.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}