const regex = /(?<![\w-])(excel|technology|technology-based|c#|software & framework|\.net)(?![\w-])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\w-])(excel|technology|technology-based|c#|software & framework|\\.net)(?![\\w-])', 'gi')
const str = `BIexcel communications excel, nibh excellent communications quis technology- software & framework C# Quisque convallis communication technology-based skills vulputate excel.
auctor excellent blandit and c++ catoon .net luctus. .net microsoft self-excel.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}