using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"unix";
string substitution = @"Linux";
string input = @"Unix is great
unix will rule the world
I like unix
linux is better than windows
Windows is closed source while unix is open source ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}