$re = '/unix/m';
$str = 'Unix is great
unix will rule the world
I like unix
linux is better than windows
Windows is closed source while unix is open source ';
$subst = "Linux";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;