package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)(\s?[0]{3}|[k]{1})`)
var str = `895k
679000
Prix: 335 000 euros`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}