$re = '/(\d+)(\s?[0]{3}|[k]{1})/m';
$str = '895k
679000
Prix: 335 000 euros';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);