package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?:\+?(\d{1,3}))?([-. (]*(\d{3})[-. )]*)?((\d{3})[-. ]*(\d{2,4})(?:[-.x ]*(\d+))?)\s*`)
var str = `0528907709
+014342342
koby douek
(052)43333
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}