re = /\s*(?:\+?(\d{1,3}))?([-. (]*(\d{3})[-. )]*)?((\d{3})[-. ]*(\d{2,4})(?:[-.x ]*(\d+))?)\s*/
str = '0528907709
+014342342
koby douek
(052)43333
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end