import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0(?:[123]|\\{.+?\\})+0)";
final String string = "01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123\n"
+ "01212121{hello 0}121312\n"
+ "01213123123123{21310030123012301}31231230123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}