import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\? {0,3}$";
final String string = "Okay if like my spacebar quite a bit? \n"
+ "Does this cryogenic chamber make me look fat?\n"
+ "You are, what, like 15?\n"
+ "fffbbcbeab?\n"
+ "4?\n"
+ ":) ?\n"
+ "Wait! Hang on. Are you going to be OK?\n"
+ "Okay if like my spacebar quite a bit? \n"
+ "bob???\n"
+ "Tom-ay-to, tom-aaaah-to.\n"
+ "Hi there!\n"
+ "It's OK if you don't want to go work for NASA.\n"
+ "1, 2, 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}