$re = '/\? {0,3}$/m';
$str = 'Okay if like my spacebar quite a bit?
Does this cryogenic chamber make me look fat?
You are, what, like 15?
fffbbcbeab?
4?
:) ?
Wait! Hang on. Are you going to be OK?
Okay if like my spacebar quite a bit?
bob???
Tom-ay-to, tom-aaaah-to.
Hi there!
It\'s OK if you don\'t want to go work for NASA.
1, 2, 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);