#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".+(\\)"
Local $sString = "C:\Users\Gary\Music\iTunes\iTunes Media\Music\Bielefelder Kinderchor\Stille Nacht, Heilige Nacht\04 Vom Himmel hoch, O Englein, kommt.mp3"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)