using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(\\)";
string substitution = @"\1";
string input = @"C:\Users\Gary\Music\iTunes\iTunes Media\Music\Bielefelder Kinderchor\Stille Nacht, Heilige Nacht\04 Vom Himmel hoch, O Englein, kommt.mp3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}