#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:\+1)?\(?([2-9]{0,1}[0-9]{2})\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$"
Local $sString = "312.876.9354" & @CRLF & _
"901-402-3541" & @CRLF & _
"(931)123-0953" & @CRLF & _
"(615) 561-0783" & @CRLF & _
"+17084223141"
Local $sSubst = "$1 $2 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)