#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\w)\d[.\d]*(?!\w)"
Local $sString = "Theses are some of the fail cases that I am looking to " & @CRLF & _
"avoid variable123 or variable_123name or _123_," & @CRLF & _
"where some of the acceptable cases are |123| or +123+ $123 123% #124523 ext... 11 2123 123% 0.12 1.1.3.4.4 12 1 23452 23423| ext...["
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")