const regex = /(?<!\w)\d[.\d]*(?!\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)\\d[.\\d]*(?!\\w)', 'g')
const str = `Theses are some of the fail cases that I am looking to
avoid variable123 or variable_123name or _123_,
where some of the acceptable cases are |123| or +123+ \$123 123% #124523 ext... 11 2123 123% 0.12 1.1.3.4.4 12 1 23452 23423| ext...[`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}