#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/(youtu.be|www.youtube.com)\/([A-z0-9-_]{11}(\?.*)?$|(watch?.*v=[A-z0-9-_]{11}(\&.*)?$))"
Local $sString = "https://www.youtube.com/watch?v=XNADRNnzP8I" & @CRLF & _
"https://www.youtube.com/watch?v=z4plxUWOHxw&t=1s" & @CRLF & _
"https://youtu.be/UW3pBCArsTg" & @CRLF & _
"https://www.youtube.com/watch?v=4HpjbvLeM3Y&t=124s" & @CRLF & _
"https://youtu.be/7Jub0c-qQGM" & @CRLF & _
"https://www.youtube.com/watch?v=vksABX_yYN0&t=1451s" & @CRLF & _
"https://youtu.be/3dHtbo5wwx4" & @CRLF & _
"https://www.youtube.com/watch?v=7QPhMbs2Bd8&t=41s" & @CRLF & _
"https://www.youtube.com/watch?v=YD2_pXJTcAU" & @CRLF & _
"https://youtu.be/9bDSzO8wtCA" & @CRLF & _
"https://www.youtube.com/watch?v=4xfNhseN25E&t=272s" & @CRLF & _
"https://youtu.be/pKUggMsbQt0?123=asd" & @CRLF & _
"https://www.youtube.com/watch?v=Vfw8dIp2Oek&t=693s" & @CRLF & _
"https://www.youtube.com/watch?v=rGYrDPnMCZI" & @CRLF & _
"https://www.youtube.com/watch?v=Sgy0N8YDYPU&t=13s" & @CRLF & _
"https://www.youtube.com/watch?v=KmhBN8CpCcc&t=53s" & @CRLF & _
"https://www.youtube.com/watch?v=dHhyJTSbCbo" & @CRLF & _
"https://www.youtube.com/watch?v=11pqaRiNyiE&t=325s" & @CRLF & _
"https://youtu.be/tYWTrORF7QA" & @CRLF & _
"https://www.youtube.com/watch?v=PQBA2FWST4s&t=7s" & @CRLF & _
"https://www.youtube.com/watch?v=Av8TwjclvV0&t=1459s" & @CRLF & _
"https://www.youtube.com/watch?v=0N0vtsHlAr8&t=732s" & @CRLF & _
"https://www.youtube.com/watch?v=LbLysiDLDYo&t=2347s" & @CRLF & _
"https://www.youtube.com/watch?v=URuA-IQmvUE&t=111s" & @CRLF & _
"https://www.youtube.com/watch?v=5kdCFpeC8as&t=532s" & @CRLF & _
"https://www.youtube.com/watch?v=a5Ck3EZkzMQ" & @CRLF & _
"https://www.youtube.com/watch?v=Gk0Slcw9IiU&t=78s" & @CRLF & _
"https://www.youtube.com/watch?v=bFIhb5xhQRM&t=155s" & @CRLF & _
"https://www.youtube.com/watch?v=37bRMNI4Nv8&t=260s" & @CRLF & _
"https://www.youtube.com/watch?v=gjC20PWBv8A&t=507s" & @CRLF & _
"https://www.youtube.com/watch?v=mGrUtnIVoTU&t=7s" & @CRLF & _
"https://www.youtube.com/watch?v=Tksj76FEWM0&t=208s" & @CRLF & _
"https://www.youtube.com/watch?v=CM0qCSVqz0U&t=551s" & @CRLF & _
"https://www.youtube.com/watch?v=NUkSxLq-jRY&t=69s" & @CRLF & _
"https://www.youtube.com/watch?v=wARglhlugmw&t=52s" & @CRLF & _
"https://www.youtube.com/watch?v=uVHlgd-ipGc&t=18s" & @CRLF & _
"https://www.youtube.com/watch?v=rq0JVTztvXQ&t=4s" & @CRLF & _
"https://www.youtube.com/watch?v=vmE4jQwkbEs&t=420s" & @CRLF & _
"https://www.youtube.com/watch?v=o_HWltTv950&t=146s" & @CRLF & _
"https://www.youtube.com/watch?v=4oroFDP4pA0&t=1057s" & @CRLF & _
"https://youtu.be/fw_RXOylU4c" & @CRLF & _
"https://www.youtube.com/watch?v=MKg2K3E7azs" & @CRLF & _
"https://www.youtube.com/watch?v=CetfYpRaJ9c&t=221s" & @CRLF & _
"https://youtu.be/lkyz58i25Xs" & @CRLF & _
"https://www.youtube.com/watch?v=W5qkaDDVTOA" & @CRLF & _
"https://www.youtube.com/watch?v=jycn7qwMVEI" & @CRLF & _
"https://www.youtube.com/watch?v=cjxe37XrQpI" & @CRLF & _
"https://youtu.be/MIqi2AgkYt8" & @CRLF & _
"https://www.youtube.com/watch?v=-cMOJyhd3BM&t=404s" & @CRLF & _
"https://www.youtube.com/watch?v=yyU7sm4DlzQ" & @CRLF & _
"https://youtu.be/uSJWi7a4fcs" & @CRLF & _
"https://www.youtube.com/watch?v=8ysrYnbEAQw&t=45s" & @CRLF & _
"https://www.youtube.com/watch?v=NrMoafPlvlg" & @CRLF & _
"https://youtu.be/uJVAkOwKs1I" & @CRLF & _
"https://www.youtube.com/watch?v=MqSO4snfEOk&t=98s" & @CRLF & _
"https://www.youtube.com/watch?v=ekedLxblmS0&t=171s" & @CRLF & _
"https://www.youtube.com/watch?v=dZ-6WmB8qyA" & @CRLF & _
"https://youtu.be/20DaWpQqDjM" & @CRLF & _
"https://www.youtube.com/watch?v=bZuaYnRPa2A" & @CRLF & _
"https://www.youtube.com/watch?v=Eve6nu2JOq0" & @CRLF & _
"https://youtu.be/MpzKeLIoLxk" & @CRLF & _
"https://www.youtube.com/watch?v=EJVGXBNNp8M&t=713s" & @CRLF & _
"https://www.youtube.com/watch?v=e1z08cdAdDg" & @CRLF & _
"https://www.youtube.com/watch?v=k3YTIgyKVOU&t=31s" & @CRLF & _
"https://youtu.be/d1bDvS6aSVQ" & @CRLF & _
"https://www.youtube.com/watch?v=owk62eGMGYk" & @CRLF & _
"https://youtu.be/BLEiCSj5zQ0" & @CRLF & _
"https://www.youtube.com/watch?v=g5XdeHy4LEY" & @CRLF & _
"https://youtu.be/FQ6M2sBmOb0" & @CRLF & _
"https://www.youtube.com/watch?v=IS9uOqtvzek" & @CRLF & _
"https://www.youtube.com/watch?v=YStRsFNgD0o" & @CRLF & _
"https://youtu.be/lCyZLHqBjrQ" & @CRLF & _
"https://www.youtube.com/watch?v=WtL1BO8LCoQ" & @CRLF & _
"https://www.youtube.com/watch?v=T_XTYAULs14" & @CRLF & _
"https://www.youtube.com/watch?v=7IP0KEgNwJU" & @CRLF & _
"https://youtu.be/7_IGRl_FwB8" & @CRLF & _
"https://www.youtube.com/watch?v=lamQWEv1wac" & @CRLF & _
"https://www.youtube.com/watch?v=gi1hJfwCO8Q" & @CRLF & _
"https://www.youtube.com/watch?v=xixi27wgudI" & @CRLF & _
"https://www.youtube.com/watch?v=Uq1NcykRak4" & @CRLF & _
"https://www.youtube.com/watch?v=ujYzPaf2aKc" & @CRLF & _
"https://www.youtube.com/watch?v=8NV7kpH9uDE" & @CRLF & _
"https://www.youtube.com/watch?v=lqvv6zvpMLE" & @CRLF & _
"https://www.youtube.com/watch?v=ZYqOUdkfWnA" & @CRLF & _
"https://www.youtube.com/watch?v=dg5fLcelcDI" & @CRLF & _
"https://www.youtube.com/watch?v=keBU3oaEXBg" & @CRLF & _
"https://www.youtube.com/watch?v=rV4tzby21x4" & @CRLF & _
"https://www.youtube.com/watch?v=tBDtUw0mm3o" & @CRLF & _
"https://www.youtube.com/watch?v=vlew8sTDxaA" & @CRLF & _
"https://www.youtube.com/watch?v=eah-0l3oj14" & @CRLF & _
"https://www.youtube.com/watch?v=vavpy-tkxEs" & @CRLF & _
"https://www.youtube.com/watch?v=htmbpUJb9sQ&t=15s" & @CRLF & _
"https://www.youtube.com/watch?v=MPHKXJdKC7Y&t=50s" & @CRLF & _
"https://www.youtube.com/watch?v=4VyoXAm2-ls&t=99s" & @CRLF & _
"https://www.youtube.com/watch?v=O3KK36CTb6Q&t=38s" & @CRLF & _
"https://www.youtube.com/watch?v=ACQtBkfxAws&t=318s" & @CRLF & _
"https://www.youtube.com/watch?v=_6bf6yFf720&t=79s" & @CRLF & _
"https://www.youtube.com/watch?v=Z8NuE57MhIE" & @CRLF & _
"https://www.youtube.com/watch?v=xAITTZqAwTU" & @CRLF & _
"https://www.youtube.com/watch?v=Bz3yBhuBtyw&t=51s" & @CRLF & _
"https://www.youtube.com/watch?v=J7jnUBCoxVk&t=26s" & @CRLF & _
"https://www.youtube.com/watch?v=DKafoAPOVfE" & @CRLF & _
"https://www.youtube.com/watch?v=_Wdq0MNCsTw" & @CRLF & _
"https://www.youtube.com/watch?v=DMJ7AGow2Ms" & @CRLF & _
"https://www.youtube.com/watch?v=17yMzN4Usp8" & @CRLF & _
"https://www.youtube.com/watch?v=a2eobordR8c" & @CRLF & _
"https://www.youtube.com/watch?v=rkouxiiQWko" & @CRLF & _
"https://www.youtube.com/watch?v=LErNVYSmmlg" & @CRLF & _
"https://www.youtube.com/watch?v=tQhT1fQQfCY" & @CRLF & _
"https://www.youtube.com/watch?v=7blDQn69970" & @CRLF & _
"https://www.youtube.com/watch?v=KeOkY7RaZ8E" & @CRLF & _
"https://www.youtube.com/watch?v=80bEG1-v3Hw" & @CRLF & _
"https://www.youtube.com/watch?v=xf726v3XRZ8" & @CRLF & _
"https://www.youtube.com/watch?v=VRhOgs3fFZk" & @CRLF & _
"https://www.youtube.com/watch?v=4VyoXAm2-ls&t=101s" & @CRLF & _
"https://www.youtube.com/watch?v=O3KK36CTb6Q&t=96s" & @CRLF & _
"https://www.youtube.com/watch?v=N6KMLAftrjk&t=16s" & @CRLF & _
"https://www.youtube.com/watch?v=rYSmIh5X6iY&t=20s" & @CRLF & _
"https://www.youtube.com/watch?v=ACQtBkfxAws&t=332s" & @CRLF & _
"https://www.youtube.com/watch?v=_6bf6yFf720&t=79s" & @CRLF & _
"https://www.youtube.com/watch?v=Z8NuE57MhIE" & @CRLF & _
"https://www.youtube.com/watch?v=xAITTZqAwTU" & @CRLF & _
"https://www.youtube.com/watch?v=Bz3yBhuBtyw&t=51s" & @CRLF & _
"https://www.youtube.com/watch?v=J7jnUBCoxVk&t=26s" & @CRLF & _
"https://www.youtube.com/watch?v=SWRasNLVfck" & @CRLF & _
"https://www.youtube.com/watch?v=DKafoAPOVfE" & @CRLF & _
"https://www.youtube.com/watch?v=-cMOJyhd3BM&t=404s" & @CRLF & _
"https://www.youtube.com/watch?v=yyU7sm4DlzQ" & @CRLF & _
"https://www.youtube.com/watch?v=_Wdq0MNCsTw" & @CRLF & _
"https://www.youtube.com/watch?v=lh_FKA1c5TM" & @CRLF & _
"https://www.youtube.com/watch?v=DMJ7AGow2Ms" & @CRLF & _
"https://www.youtube.com/watch?v=17yMzN4Usp8" & @CRLF & _
"https://www.youtube.com/watch?v=TKSU40dCVwQ" & @CRLF & _
"https://www.youtube.com/watch?v=eMAXGmhFupo&t=1s" & @CRLF & _
"https://youtu.be/MpzKeLIoLxk" & @CRLF & _
"https://www.youtube.com/watch?v=EJVGXBNNp8M&t=713s" & @CRLF & _
"https://www.youtube.com/watch?v=pPq6IkJme0s" & @CRLF & _
"https://www.youtube.com/watch?v=1cIzQ2xq3Kw" & @CRLF & _
"https://www.youtube.com/watch?v=heG18vkVJyo&t=32s" & @CRLF & _
"https://www.youtube.com/watch?v=mVAHph7QpJM" & @CRLF & _
"https://www.youtube.com/watch?v=FhQ9xSK0oiY" & @CRLF & _
"https://www.youtube.com/watch?v=Abctipv1Aqk" & @CRLF & _
"https://www.youtube.com/watch?v=9Kf3EZPUOkk" & @CRLF & _
"https://www.youtube.com/watch?v=PasZLvRYMR4" & @CRLF & _
"https://www.youtube.com/watch?v=keBU3oaEXBg" & @CRLF & _
"https://www.youtube.com/watch?v=5I1ms4q94uk" & @CRLF & _
"https://www.youtube.com/watch?v=gwfh4DuS7GQ" & @CRLF & _
"https://www.youtube.com/watch?v=xxRB6ozPgQM" & @CRLF & _
"https://www.youtube.com/watch?v=Zq6QfT3017M"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")